WiFi won't connect & MyQ won't register

  • 14
  • Problem
  • Updated 2 months ago
I bought and installed two Chamberlain 1.25 HP belt-drive garage door openers (Model HD950WF) from Home Depot this weekend.  Neither of the MyQ serial numbers will register on the Chamberlain website (I get the error, "That gateway or hub serial number was not recognized").  I opened the units and verified that the MyQ serial numbers on the unit match the serial numbers on the circuit boards.  Also...neither garage door opener will connect to my WiFi network.  I've moved my router out in the garage; I've tried different WiFi routers; I've also tried connecting to my WiFi network via Android, Apple, and PC devices using Chrome, Firefox, Safari, Explorer, and Opera web browsers.  I've conducted several resets.  Whenever I try to connect either garage door opener to any WiFi network, the browser hangs on, "Scanning for available networks, please wait".  All the other functions on both garage door openers perform as expected.  By the way...I live in Oro Valley if anyone from Chamberlain tech support is willing to come north.  I have a cold Barrio Blonde waiting for anyone who wants to help. :-) 
Photo of Jason Smith

Jason Smith

  • 3 Posts
  • 0 Reply Likes
  • frustrated

Posted 2 years ago

  • 14
Photo of Amir Dekel

Amir Dekel

  • 1 Post
  • 0 Reply Likes
MyQ worked for a solid year and then one day 1st door went offline then two days later 2nd one went offline. I tried to reset and reconnect and erase all devices, but nothing worked. So then I looked at my Wifi Analyzer app and saw that my neighbor was using up all the channels between his routers and extenders. I saw that channel 3 was kind of clear and changed my router setting accordingly. Once that was done both doors connected with no issue.

TLDR: Find a clear channel for your router other than the default that may be getting interference from a neighbor.
Photo of MyQ Community Manager

MyQ Community Manager

  • 2294 Posts
  • 145 Reply Likes
Amir, we are glad to hear you found a resolution and appreciate you sharing it with the MyQ Community. Thanks, Chuck
Photo of Mark Geraghty

Mark Geraghty

  • 2 Posts
  • 0 Reply Likes
also be clear that you must have a 2.4ghz wireless.... most of us including me... have a modern 5ghz network.. . from the vendor page:

MyQ Garage only (Does not work for Smart Garage Hub) -
If using the iPhone Bluetooth for setup, verify that the wireless router is on a 2.4GHz frequency. The hub will not connect to router if the router is set to only operate at 5GHz frequency. If you are unsure how to check this, contact your router manufacturer

5GHz
The Wi-Fi product will not connect to a router if the router is set to only operate at 5GHz frequency. The MyQ Wi-Fi product only works on 2.4GHz frequency. If you are unsure how to check this or make the adjustment, contact your router manufacturer.
(Edited)
Photo of John Hughan

John Hughan

  • 10 Posts
  • 1 Reply Like
I don’t know of any routers or access points that offer ONLY 5 GHz though, so this doesn’t seem like a significant drawback. Also, lots of IoT-type devices only support 2.4 GHz because it’s less expensive, consumes less power, and has longer range. It doesn’t offer as much bandwidth, but that typically isn’t a priority on IoT devices. And if your router is hosting both frequencies, clients connected on one band can communicate with clients on the other. In fact it’s a common practice to name the 2.4 and 5 GHz networks identically so that each client can select the band that works best for them at any given time. For example, a laptop that moves around might sometimes perform better on one band or the other. If the networks are named uniquely, then it will stick to the higher-ranked network in its list until that network is unavailable. If the networks are named identically, then it might switch to the other band automatically when it would perform better by doing so.
(Edited)
Photo of Mark Geraghty

Mark Geraghty

  • 2 Posts
  • 0 Reply Likes
my router can be switched to perm 5ghz, which i had it on. now i have to slow down my entire network just for this garage door opener if i want phone access. (Ubiquity Amplifi)
(Edited)
Photo of John Hughan

John Hughan

  • 10 Posts
  • 1 Reply Like
Unless your router/access point has a sadly underpowered CPU, having 2.4 GHz active will not slow anything down. Any router that can run both bands simultaneously has separate radios for each band, and the two bands operate in completely different areas of the radio spectrum that do not interfere with each other. Enabling 802.11b support rather than restricting the network to only G or N clients can slow down everything on your 2.4 GHz band, but having 2.4 GHz active will not have any impact on the performance of 5 GHz clients, again unless your router/access point has underpowered hardware, which a Ubiquiti product wouldn’t.
Photo of Manfred Wilner

Manfred Wilner

  • 1 Post
  • 0 Reply Likes
As I discovered a similar problem not being able to re-connect to the WiFi after the network changed I had at first the same trouble as many here.
The best method seems to be to use a Laptop as described by John and re-configure the hub and then reconfigure the phone app installing a new hub and door sensor.
The most tricky part is the connection to the WiFi which even with the PC took several attempts as the connection several times timed out due to very slow response of the hub.
This clearly is a bad design on the part of Chamberlain and I would hope they could update the hub firmware to improve this process.
Once the hub was on the Network the final re-configuration within the phone app was going rather smooth.
Photo of Kerry Hubbard

Kerry Hubbard

  • 1 Post
  • 0 Reply Likes
This is nuts. What about "normal" people like me--mid-50s, reasonably intelligent, but not a tech professional? I bought two new doors, with two new openers specifically so that I could operate the doors remotely. When trying the MyQ set-up process, my Wifi network doesn't even show up although my phone shows a strong connection in the garage (the router/modem is on the exact opposite side of the same wall as the openers). I tried to go to the web address given on the manual specifically for connectivity issues. It is a private locked page that requires a sign in and password. The wall buttons in the illustrations looks nothing like the buttons installed in my garage. Lastly, I think mine are crap anyway, because the lights won't go off. The installation tech has already come back and replaced some electronic board once. I've connected many smart devices before. Absolutely can't understand why this is so difficult. 
Photo of Lori

Lori

  • 2 Posts
  • 0 Reply Likes
I'm having a similar issue as many people have posted.  I just installed my garage door opener yesterday and I can't get the wifi to hook up.  When I try to connect to the MyQ-xxx network, I select it and it looks like it connects, but then says no internet connectivity and the setup.myqdevice page says it's not connected to my wifi network.  The middle button (with the black square) is a solid blue.  I'm using an iphone to connect, and turned off the WIFI assist as instructed.  I've tried following the reset instructions that some have mentioned, but I don't get the same result.  I tried moving my wifi extender into the garage, and that didn't work either.  As with many people, I've had no trouble hooking up any other smart devices throughout my home, so I'm not sure what the issue could be. 
Photo of John Hughan

John Hughan

  • 10 Posts
  • 1 Reply Like
Do you have a WiFi-equipped PC you can use instead?  The iPhone is a bit finicky for this task because by default when it joins a WiFi network and detects that it does not provide Internet access, such as a garage door opener's access point, it typically disconnects, even if WiFi Assist is disabled.  There is a way you can choose to stay connected, but it can be tricky to get that prompt to appear.  So if you haven't already, try using a PC.
Photo of Lori

Lori

  • 2 Posts
  • 0 Reply Likes
Do I need to turn my iPhone off to do it with a laptop, or does that not impact anything?
Photo of John Hughan

John Hughan

  • 10 Posts
  • 1 Reply Like
It shouldn’t matter, although if you won’t be using the iPhone to configure the garage door opener, there’s no point having it connected to the MyQ WiFi network. Just connect your laptop to that MyQ network and follow the setup instructions from the laptop instead. If all goes well, the MyQ network will disappear because the garage door opener will join your home’s WiFi network at that point.
(Edited)
Photo of Steve

Steve

  • 2 Posts
  • 0 Reply Likes
I have sadly ran into the same issue with my Asus RT-AC66U.    I am able to connect to the temporary WIFI created by the opener, but when I attempt to connect it to the strong house WIFI, it just sit there never beeping or anything.  It never connects.   I have a separate spare fortigate firewall; when following the exact same steps it connects up no problem.    

I have made sure only 2.4Ghz is on, removed all security and passwords.    I honestly don't know what else to try other than give up.
Photo of John Hughan

John Hughan

  • 10 Posts
  • 1 Reply Like
Try firmware version 3.0.0.4.380_7743.  That's what I'm running on my ASUS RT-AC88U, and that same version is available for your AC66U.  Unfortunately none of the newer router firmware versions work correctly with the garage door opener, which is unfortunate since they fix some security issues, but 7743 is the latest one that's solid.  I'm not sure if the fault for this lies with ASUS or Chamberlain, but at least in my case, downgrading to 7743 fixed my connectivity issues.  The firmware page link is below, then just click "Show All Downloads" to access the earlier firmware releases. https://www.asus.com/us/Networking/RTAC66U/HelpDesk_BIOS/
Photo of Steve

Steve

  • 2 Posts
  • 0 Reply Likes
I'll give it a shot, thanks for the reply.
Photo of Dominic

Dominic

  • 1 Post
  • 0 Reply Likes
Hello All,

or those of you who are still dealing with issues connecting the Chamberlain Garage Hub to your WIFI network, here is how I resolved my issues... after hours of research and frustration!

First of all, make sure your WIFI network is properly configured to allow the Hub to connect to your network : (https://support.chamberlaingroup.com/s/article/Why-won-t-the-Wi-Fi-Garage-Door-Opener-or-MyQ-Garage-...)

Then, if you still can't join the Chamberlain Hub to your WIFI Network, same issue I had and I tried everything going from resetting the device to unplugging it ... and trying to tweak my WIFI Network!

From your smartphone, go to settings / WI-FI / and join the Chamberlain Hub Wifi Network

Now that you are connected to the Chamberlain WIFI Hub, look at the IP address for the gateway (mine was 192.168.10.1 I believe)

Still on your smartphone, Open your Web Browser and type the gateway address

You should now be connected to the Chamberlain Hub, from there erase the previous WIFI settings and start from "scratch"

Follow the instruction and you should be able to connect the Chamberlain Hub to your WIFI Network from there (I worked for me)!

Then go back to the Chamberlain APP and follow the instruction, your Hub should appear and be connected already.

Don't forget to open port 8883, in my case my firewall was blocking it and it prevented my Chamberlain Hub to complete its connection to the Internet (https://support.chamberlaingroup.com/s/article/Recommended-router-settings-for-the-MyQ-Wi-Fi-product...)

Voilà!  Hopefully this solution will work for you as it worked for me!  Feel free to let me know if you have question!
Photo of mrouseoma

mrouseoma

  • 1 Post
  • 0 Reply Likes
I'll give this a try--thank you!  I bought a new iPhone XR yesterday, and it won't connect to the Liftmaster garage door opener.  My prior iPhone 7 worked fine.  I didn't change anything else--same router, same router location, same modem, etc. Insane how difficult it is to get this device to connect!
Photo of BryanV

BryanV

  • 1 Post
  • 0 Reply Likes
In my case my the issue was my phone (Google Pixel 2 running Android 9.0) would try to connect to the temporary wifi network (MyQ-xxx) the opener (B970) was creating but the phone kept trying to disconnect since the temp network doesn't have internet access. You're simply temporarily connecting to the opener to then tie your home wifi to the opener.

I used the MyQ app setup process. Clicked the + to add a device, turned on the wifi setup using the opener wall control as instructed, clicked the opener name (MyQ-xxx) and then as it was searching I opened my wifi settings on the phone and clicked the matching temp network (MyQ-xxx).

This locked the phone to that MyQ-xxx network so the phone wouldn't keep disconnecting. The phone also popped up a notification saying something like "this network doesn't have internet access do you want to remain connected?". I clicked yes and I think that step was key. I ignored the pop up at first and didn't have success until I acknowledged I wanted to remain connected.

The rest was simple. The MyQ app made the connection between my phone and the opener, I selected my home wifi network, entered that password and voila I was in business. The opener now shows up in the app and works as expected.

Hope this helps someone as I was getting pretty frustrated trying to change settings in my router to make it all work.

Photo of Tom

Tom

  • 2 Posts
  • 0 Reply Likes
Two years later and they still have the same problem?  I just installed 2 B970 openers. Everything installed fine and they both were controllable from the app.  Then a day later both openers went offline. I installed a range extender thinking that might be the problem.  When I use the wall controller/app to log onto the wifi it skips the step where I choose the wifi connection I want and the app takes me thru a diagnostic mode where the openers beep and light like they are supposed to then the app takes me to a website that provides no help at all.  Tried removing all power and restart with the same problem.  Two units fail in the same way at the same time.  It's not my wifi, it's the units. 
Photo of Wes Soldani

Wes Soldani

  • 1 Post
  • 0 Reply Likes
I was having this problem, I figured out that the problem was my phone was connected to my wife. You have to "forget your network" in your wifi setting. Then try and connect ur myQ app.