Unable to setup MyQ Hub with Home Bridge

  • 1
  • Question
  • Updated 6 months ago
I setup the MyQ Hub with both my door sensors. No problem there. Next I went through the steps for setting up MyQ Home Bridge.
First garage door was added, when trying to add the 2nd one it suddenly wanted to learn the garage door for that it again. Did not make sense to me. I continued with it anyway and then it came back stating it was unable to control the 2nd opener and could monitor only. Weird, as just before I was able to configure my hub and it worked with both doors.

Then when I went back, nothing there anymore. Everything is gone. Like I never did the setup. Guessing trying again. Went through all the reset, factory resets, ... steps.

Now when I go through the steps, it is flashing the blue light (good). I click continue at which point I normally am asked to which WiFi network  to connect to and then password. No go, it immediately states that I am connected to WiFi. When I check, blue light is still flashing. Would expect to see a green light now.
Going on, now going to pair the door sensor. Follow instructions as I did before twice and through it able to connect them. No go this time. No beep, nothing. On the App it just keeps on spinning as well waiting for the pairing to happen.

Thus, how do I proceed from here? How do I get the hub back connected up to both my garage door sensors AND then continue with linking it to the bridge allowing me to use it with HomeKit. 

The support site is down as well. But I did follow steps found on the internet and from this forum for both doing the reset and setup. I also deleted to app from my phone and then downloaded it again.
Photo of Erik Hendrix

Erik Hendrix

  • 8 Posts
  • 1 Reply Like
  • very frustrated

Posted 8 months ago

  • 1
Photo of Rockster


  • 4 Posts
  • 0 Reply Likes
Try this YouTube video, it worked for me.
Photo of Erik Hendrix

Erik Hendrix

  • 8 Posts
  • 1 Reply Like
Thanks for the video, but it does not show how to do the transfer for the devices from MyQ Hub to MyQ bridge. 

I called technical support. With their help I was able to get the Hub working again. This was done first by resetting the WiFi on the Hub again (was done just to make sure even although the blue light was blinking):
  1. Press and hold the Settings button (gear) on the Wi-Fi hub until the blue LED blinks then release.
  2. While the blue LED is blinking, press and hold the Settings button (gear) again until the blue LED pauses then blinks or beeps. The Wi-Fi hub is set to factory default.

Next, on my phone we connected it to the Hub (shows as MyQ with last 2-3 digits of serial number in the available WiFi list).
Once the phone is connected, opening browser on the phone and going to: setup.myqdevice.com. From there I could then actually re-do the WiFi connectivity (which is what had to be done). 
Then on the App, instead of adding a Hub we went to add a Internet Gateway. And once that was added in the app continued with adding the doors. I've done this now at least 5-10 times so pretty good and confident I can easily add them.

Next was adding the bridge. As we were in process however the call dropped, right at the point for transferring the devices. Had to go somewhere so left it at that (Hub worked).
When I came back, called them up again. This time a different agent. Informed him I had called earlier, where I was in the process and what had to be done next.
So he continued asking me to push and hold the button on the hub. Sounded strange to me but followed his advice. After I did that, he informed me "oh, now your devices are gone!". No sh*t Sherlock. Let's restart the whole Hub setup again then.

OK, Hub set up. Now the bridge. Advice he gives me to transfer the devices is just not working at all. Not even sure he knew what had to be done and was just reading the same instructions we all received with the product which are wrong. 
As I'm on the phone with him, I ended up trying what someone had mentioned here before with pressing the #1 button on the bridge twice and then on the hub once. That worked. Did it for the 2nd one, worked as well. Cool!
Check in HomeKit, both doors are there. Next let's test it. I press it in HomeKit, door operates and closes (door was open). Now I open the door from my wall button, this to confirm that when the door is opened through another way that it reflects accurately in HomeKit. 
Nope, in HomeKit it keeps on saying my door is closed. WTF! He inform him about this. And then came his best advice ever. To check if the door is open or closed, go and check in the garage. 
Well, if that was the plan then I would not have bought this whole thing. He then just wished me a nice day and to call back if there are any other issues (you mean like status in HomeKit is not accurate?). Clearly getting this setup was out of his comfort zone, but why he then does not admit and to then state he will transfer me to someone who knows this stuff better, instead of leaving the customer hanging there I do not know.

So I try some stuff for the rest of the evening (note, I think they say this is setup in like 15 minutes. Figured by now spent about 8-12 hours on this including over 2 hours with technical support). In the end, Hub is working and Bridge is not. Left it there. I also have Home Assistant running and integrated my garage doors into HomeKit from there, that took me about 5 minutes BTW!

This was like 36 hours ago. Yesterday I then used HomeKit (configured through Home Assistant not the Bridge)  to open/close the door, check status, all works .

Well, today I noticed that Home Assistant was giving problems. Hmmm. I open the App for MyQ on my phone and it welcomes me stating there are no devices and kindly offers me the screen to add MyQ. WTF!!!! Maybe an issue with the app. Let's go to the actual portal online. Well, same deal.
So now my Hub disappeared as well. Green light is on.

As I mentioned, I can easily get the Hub back on. Can pretty much do it blindly know as I've already done it so much. But how can that stuff just disappear? And no, there was no power or internet outage whatsoever (and even if there was, it should be able to come back online without issues).

Now, I have the Liftmaster 821LMB Hub with the LiftMaster 819LMB bridge. Per my understanding this is similar as the Chamberlain MyQ-G0301 hub and MyQ-G0303 Bridge.

My next step if first off all to call technical support again as I would really like to know from them how these things just disappear.

Then my plan is to get the Hub setup again. I also believe I know what I missed from steps that were provided here. I always also continued within the app for transferring the devices. I guess instead for transferring the devices I only go through step 1:
  1. Click Yes to add your existing devices to your MyQ Home Bridge.
And from then on stop using the App and instead do:
MYQ Smart Hub: Solid green - Press and hold gear button - release when you get a blinking blue light.

1) On the bridge press and release button # 1 twice (blue - green - amber light up)

    A) on the hub press and release button # 1 once

2) On the bridge press and release button # 2 twice ((blue - green - amber light up)

  A) on the hub press and release button # 2 once

And hopefully that works. 

To be continued.

Photo of Erik Hendrix

Erik Hendrix

  • 8 Posts
  • 1 Reply Like
And the saga continues.

Called technical support and they could not give me any explanation at all on why my devices were gone. Only thing they could say was that last time they are "seen" was yesterday evening at 9PM. Great.

Added again to the hub (as mentioned, becoming an expert ... thinking in putting a "for-hire" sign outside for this part).

Next trying to add the bridge. Still major fail. Tried the steps I mentioned above, did not work. 

Now, here is what is weird to me. I go into the App to transfer the devices. I select my 1st garage, it then tells me to press the gear button to reset the wifi on the hub. I press the gear button and the blue light is blinking.
HOWEVER, when I then click next or so it sits there and then asks me if the blue light is blinking. This would seem to me that whatever it is looking for, it is unable to do so. Now I can click "No" and that does not get me anywhere.
If I click "Yes" (as it is blinking), no matter what steps I follow then for pushing the buttons etc.. (be it what the App states, be it what I mentioned above, be it any combination); it does not work.
So my guess is that the 1st issue already is that even although the blue light is blinking, something is not right and then no matter what I do; it will not work. 

Any advice on getting this done is appreciated. Technical support (in my humble opinion) seems rather clueless on this (or I always get those that are clueless).
Photo of frank


  • 2 Posts
  • 0 Reply Likes
I have been trying to get my bridge set up with my 2 door for 6 day.  Called support at least 4 times and must have been on the phone for 3 hours or more.  My problem has been escalated and waiting for a call back.

There are obvious issues with this HomeKit box.