Unable to add Chamberlain Garage Master with green learn button

  • 1
  • Question
  • Updated 9 months ago
I have been trying to add my older Chamberlain Garage Master opener through the app using the proper instructions but the app just sits there and spins and then returns that no device has been added. So I found some manual instructions using the MyQ hub to add the opener and I got it to open and close with the hub. However the app doesn't recognize that I added the device manually. I don't really understand what is going on here. Can anyone offer some assistance?
Photo of James Luongo

James Luongo

  • 5 Posts
  • 0 Reply Likes
  • Frustrated

Posted 9 months ago

  • 1
Photo of chris

chris

  • 48 Posts
  • 1 Reply Like
Follow the app setup instructions but when asked what color button is on the gdo, tell the app a different color than what actually exists on your opener. I had this issue on my moms craftsman gdo. Once I found the right color it setup immediately and works great.

I’ll guess that now your app works maybe your remotes no longer work?
(Edited)
Photo of James Luongo

James Luongo

  • 5 Posts
  • 0 Reply Likes
I don't see an option to set the color of the button in the app. The flow is as follows:

I go to Manage Places and select the place for my MyQ device, which I call Home
Then I hit the + button to add a device
The next screen asks to select the device I want to add. I choose Garage Door Opener
The next screen asks if I'm using a door sensor. I choose No as I don't want to use the MyQ door sensor
The next screen says "Walk up to your Garage Door Opener and locate its Learn Button". I click next.
Then "Now, press and release the Learn Button on your Garage Door Opener." and it spins. This is the point that I press the learn button, but nothing happens.

That's why I switched to using the manual method.
Photo of MyQ Community Manager

MyQ Community Manager, Employee

  • 2294 Posts
  • 137 Reply Likes
James, green ‘learn’ buttons can sometimes be tricky to install on hubs. Try using the ‘red’ instead of ‘green’, when asked the color of the ‘learn’ button during MyQ set up. Let us know how that goes. Thanks, Chuck
Photo of James Luongo

James Luongo

  • 5 Posts
  • 0 Reply Likes
So are you saying to choose the frequency for red button openers when doing the manual programming? Because like I mentioned before I do not have an option of choosing the button color when using the app to do the programming. I'm not sure if that's an issue with the app or not.
Photo of MyQ Community Manager

MyQ Community Manager, Employee

  • 2294 Posts
  • 137 Reply Likes
James, that's good information. Let's get you connected to our support team through your MyQ community email. Someone will be reaching out to you soon. Thanks, Chuck
Photo of James Luongo

James Luongo

  • 5 Posts
  • 0 Reply Likes
I was contacted by customer support and the issue was resolved. Thanks so much!

To share the resolution: if you are using an older green button door opener and trying to add it with the app, you need to also program the door sensor. Otherwise the app won't know if the door is open or not.
Photo of chris

chris

  • 48 Posts
  • 1 Reply Like
Oh my. Yes. I thought you implied you did not require the sensors. Glad you got it fixed.
Photo of James Luongo

James Luongo

  • 5 Posts
  • 0 Reply Likes
And yes, my remote stopped working when I got the opener working in the app. Hoping I can just resync it so that both devices can work.