Two MyQ-integrated openers in one 'Location'?

  • 4
  • Question
  • Updated 2 weeks ago
I have two identical MyQ-integrated garage door openers in my garage, both having their own integrated MyQ gateways.  When I added the first one, there's no problem.  Created a location called 'Home', typed in the MyQ serial number.  Adding the second garage door opener to 'Home', it wants me to use the Learn button and nothing ever works.

The only way I can seem to have both garage door openers in one app is to have two separate Locations, which means I can't have both garage door openers on my phone screen simultaneously.

It just feels dumb that two separate openers need to be in two separate locations.  How many people using this app have multiple garages on multiple properties?
Photo of Paul Huskey

Paul Huskey

  • 3 Posts
  • 1 Reply Like

Posted 2 years ago

  • 4
Photo of NateX

NateX

  • 2 Posts
  • 1 Reply Like
I have the same issue.  I think that each one is it's own gateway, and the software is not coded to accept multiple gateways at the same "location".  I registered both of mine before trying to resolve the multiple location issue, but I wonder what would the result be if one didn't register the second gateway, and just added it to the first location as an opener.  That might be the way Chamberlain intended it to work.  Either way, documentation on this SUCKS, and they need to address this.  There are a lot of homes with more than one GDO nowadays.  This is a pretty common setup, and I can't believe they didn't have this as use case for rollout.  Poor execution by the product development team IMO.
(Edited)
Photo of Jim

Jim

  • 70 Posts
  • 10 Reply Likes
If you desire one MyQ "Place" with two WI-Fi Garage Door Openers (GDO) at the same location, here is what to do:
  1. Determine which GDO will be the main GDO (either can be, best is probably the one closest to the home Wi-Fi router).
  2. Setup the Wi-Fi on the main/first GDO (in your cases, the Wi-Fi is already setup on the GDO).
  3. In your cases, delete the second GDO from the MyQ app (Menu/three bars > Manage Places >  [your home/place name] > tap delete symbol for second GDO > ...)
  4. Erase the Wi-Fi settings from the second GDO.  Wi-Fi Erase: Press and hold pressed the Adjustment button (black button between the Up and Down arrow buttons) for at least 6 seconds until the green LED turns off or begins blinking blue on/off. 
  5. With the MyQ app, add the second GDO to MyQ: Add (+) > Add Device to [your home/place name] > Garage Door Opener > ... [follow remaining app instructions]
This will add the second GDO to the first/main GDO's gateway.  You will have one Place and two openers on MyQ.  

If you have more than two Wi-Fi GDOs, use the same instructions, repeating steps 3 - 5, for each additional Wi-Fi GDO at the location.
(Edited)
Photo of NateX

NateX

  • 2 Posts
  • 1 Reply Like
Thanks for the reply @JMurray!  I suspected something like this would work, but just haven't had time to try it.  I will give it a shot and report back.
Photo of Elliott Wohlferd

Elliott Wohlferd

  • 1 Post
  • 0 Reply Likes
Thanks!  I had the same problem and this worked perfectly!
Photo of C P

C P

  • 1 Post
  • 0 Reply Likes
Perfect solutions. Couldn't believe, this is not listed on their website or user manual. Thanks for the solution.
Photo of MyQ Community Manager

MyQ Community Manager

  • 798 Posts
  • 43 Reply Likes
C P,

I'm glad you found the information you needed. 

Let us know if you have any other questions. 

Best, 
Chuck
Photo of Tyler Williams

Tyler Williams

  • 1 Post
  • 0 Reply Likes
I have four door openers in my garage and am witnessing the "four places" complaint.  I have tried to follow Jim's above instructions, however when I try to delete any of the four places I receive a message "Center Door is permanently linked to Home and cannot be removed.  To remove garage door, go to Manage Places and remove home (601)."  I am doing exactly what the message is saying to do.  What gives?
Photo of MyQ Community Manager

MyQ Community Manager

  • 2294 Posts
  • 143 Reply Likes
Tyler, I've asked a customer support agent to reach out to you. Look for an email tomorrow. Lauren
Photo of Eloy

Eloy

  • 1 Post
  • 0 Reply Likes
I was not able to delete the 2nd place through the app but when I logged into MyQ account online I was able to delete the 2nd place. I then erased the wifi settings by placing the smart controller into program wifi and then holding the black rectangular adjust button on the head unit until 3 beeps. Then go into place 1, click add a garage opener, follow the instructions to press the learn button on the 2nd garage opener and it should automatically be added to place 1.
Photo of John

John

  • 2 Posts
  • 0 Reply Likes
My issue may be a little different.  I have added 2 openers under a single gate way.  For example, Garage Door A and Garage Door B were both created under Garage.  I'm running 2 door sensors and a 201 hub.  I set everything up, but opening either door from the app will open both doors.  Same thing for closing them.  Any suggestions?
Photo of MyQ Community Manager

MyQ Community Manager

  • 2294 Posts
  • 143 Reply Likes
John, are you looking to have them open and close independent of one another? Thanks, Chuck
Photo of John

John

  • 2 Posts
  • 0 Reply Likes
Yes, I am.  
Photo of MyQ Community Manager

MyQ Community Manager

  • 2294 Posts
  • 143 Reply Likes
John, I've asked a customer support agent to reach out to you directly for assistance. Please look for an email. Thanks, Chuck
Photo of Stacy Purves Jackson

Stacy Purves Jackson

  • 1 Post
  • 0 Reply Likes
John or MyQ Community Manager- Did you find a resolution for this?  I'm having the same issue as John.  Single gateway, 2 openers.  Currently they only open and close simultaneously. 
Photo of MyQ Community Manager

MyQ Community Manager

  • 2294 Posts
  • 143 Reply Likes
Stacy, thanks for the info. A team member will email you shortly with steps to help you solve the issue. Please look for an email soon. Thanks, Chuck
Photo of Jill

Jill

  • 1 Post
  • 0 Reply Likes
I am having the same issue as Stacy.  Can you have someone email me to resolve this issue?
Photo of MyQ Community Manager

MyQ Community Manager

  • 2294 Posts
  • 143 Reply Likes
Jill, no problem. I'll have a team member reach out to you shortly. Please keep an eye out for an email. Thanks, Chuck
Photo of Craig

Craig

  • 2 Posts
  • 1 Reply Like
I am having the same problem.  I followed the instructions listed above, but the 2nd opener will not join the hub - the MyQ app times out.   As other have mentioned, after pressing LEARN twice on the remote controller, both openers blink, indicating it's probably working.  But in the end, the 2nd opener does not join.

I had two B750 openers installed this past week.  Love 'em so far.
(Edited)
Photo of MyQ Community Manager

MyQ Community Manager

  • 2294 Posts
  • 143 Reply Likes
Craig, thanks for the info. A customer support agent will email you shortly for assistance. Chuck
Photo of Craig

Craig

  • 2 Posts
  • 1 Reply Like
Thanks.  Roger did reach out to me soon after you posted this, and after a couple emails, we decided a phone call would be best.  He asked me what time would work well, I told him, and he called right on time (late afternoon).  Super polite and walked me through the process.  I'm still not sure why it did not work when I tried it the previous 10 times, but sure enough, while he was on the phone, it worked the first time.

I had one opener already on the wi-fi and working via the MyQ app.  To add the 2nd, on the MyQ app I went into Device Management, selected the Hub, selected +, selected Garage Opener, Selected next, waited about 8-10 seconds, pressed and released the yellow button of the 2nd opener, and it immediately connected.  Both openers now show up on the MyQ app under one hub/location.

Thanks, Chamberlain Support!

-Craig
Photo of MyQ Community Manager

MyQ Community Manager

  • 2294 Posts
  • 143 Reply Likes
Craig, thank you for sharing the resolution our support team helped you reach. Hopefully will help others who may find themselves with the same questions as you. Thanks, Chuck
Photo of Joe Cordell

Joe Cordell

  • 2 Posts
  • 0 Reply Likes
Craig, I had exactly the same problem with my second door opener not joining the Hub. I was unsuccessful with your instructions until I went to DEVICES on the app, not device management. With that substitution, your instructions were right on! Thanks for your help and I hope this helps others out there with double door garages!
Photo of Paul Huskey

Paul Huskey

  • 3 Posts
  • 1 Reply Like
I kind of want to try this but ended up, next to the + button is one for views. One of the views shows both my garage doors simultaneously so i just stick with that one.

Photo of Joe Cordell

Joe Cordell

  • 2 Posts
  • 0 Reply Likes
Paul, That's it! You have both doors on the same screen and can control either one or both from that page, Congrats!
Photo of Greg Johnson

Greg Johnson

  • 1 Post
  • 0 Reply Likes
I am having the same problem. Tried everything on here and none of it works for
Me
Photo of Will

Will

  • 4 Posts
  • 0 Reply Likes
I have been trying to figure this out for 4 weeks. Why isn't this in the manual?? Thanks.
Photo of Steve

Steve

  • 1 Post
  • 0 Reply Likes
I have this same issue and tried to follow the instructions above, but I get stuck after pressing the "learn" button on the new garage door opener. Both door openers blink their lights which makes me think the learn worked, but the app still says "Waiting for device..." and eventually times out.
Photo of Ives Laurent

Ives Laurent

  • 3 Posts
  • 0 Reply Likes
I have a working Gateway with one GDO configured no problems at all, but I just bought a second GDO for another door in the same location. I proceded with the installation and tried to add the new GDO to the same location already set and working wth what is my main GDO BUT when pressing the learn button it apparently starts linking to the Gateway a few seconds later the light turns out which would indicate this has been a success but unforntunatky the app continues in the searching device and times out.
Any ideas on what could I try?
By the way my Gateway is connected through ethernet not WiFi
(Edited)
Photo of MyQ Community Manager

MyQ Community Manager

  • 2294 Posts
  • 141 Reply Likes
Ives, I am looking into this for you. Lauren
Photo of Ives Laurent

Ives Laurent

  • 3 Posts
  • 0 Reply Likes
Thanks.
Just to let you know what else I have tried...
In my latest test, I remove everything setup everything from the buttom. My GW setus up without problems, the first GDO without problems and ths second stills has the issue. BUT I noticed something when I click the learn button a second later it turns off and a little click sound comes from the motor, but the app still remains searching.
The motors and GDO are exactly the same moddel.
Photo of MyQ Community Manager

MyQ Community Manager

  • 798 Posts
  • 43 Reply Likes
Ives, thanks for these details. Can I have someone from our tech support team reach out to you using the email address associated with this account? Lauren
Photo of Ives Laurent

Ives Laurent

  • 3 Posts
  • 0 Reply Likes
sorry i was out of the country.
please feel free to contact me through email, the same registered here.
Photo of MyQ Community Manager

MyQ Community Manager

  • 2294 Posts
  • 141 Reply Likes
I'ves, thanks for the info. A customer support agent will reach out to you via email shortly. Thanks, Chuck
Photo of Gustavo Raposo

Gustavo Raposo

  • 3 Posts
  • 0 Reply Likes
I have a very similar issue. I have two intergrated wifi garage door openers (Liftmaster) I got one added to my wifi via adding logging into the website while connected to its wifi. Then got it on my wifi, and added it to the myq app no problem. Next, I did the same and got the second door onto my wifi without any issues. I go into the myq app and it wants me to add it via the learn button instead of just typing in the serial number. I have not done the new "place" method as I want it to be at the same place. 

Can you help? Maybe a tech support person can just add the serial number to my "place" since its already online. 
Photo of MyQ Community Manager

MyQ Community Manager

  • 2294 Posts
  • 143 Reply Likes
Gustavo, When a MyQ device is connected to Wi-Fi it must be added as a new place by entering the MyQ serial number. If you want to have both your Wi-Fi GDOs under the same place in the app/website, the best option would be to clear the Wi-Fi memory of the second opener which will allow the learn button programming they are attempting through the app to go through and add the second opener as a device under the place created with the first ones MyQ serial number.

The instructions for clearing the Wi-Fi memory:

1) Press and hold the black adjustment button on the garage door opener until 3 beeps are heard. There is an initial beep, continue to hold the button approximately 6 seconds, during this time the up arrow will be flashing.  

2) Wait a few seconds for the LED light to turn off. Wi-Fi settings are clear.

Please let me know if you have any other questions. Lauren
Photo of Gustavo Raposo

Gustavo Raposo

  • 3 Posts
  • 0 Reply Likes
After that I can just do learn to add to the same place? any tricks to this?
Photo of Gustavo Raposo

Gustavo Raposo

  • 3 Posts
  • 0 Reply Likes
What is it actually doing when I say do learn? Do I connect to its wifi at that point? 
Photo of MyQ Community Manager

MyQ Community Manager

  • 2294 Posts
  • 143 Reply Likes
Gustavo, Once the Wi-Fi memory on the second unit has been cleared, follow the instruction in the app when adding a device, and press the learn button on the second unit and that will connect the second opener to the firsts Wi-Fi connection.
Lauren
Photo of sandeep sheth

sandeep sheth

  • 1 Post
  • 0 Reply Likes
Hi Lauren,

I am facing similar issue. I added one garage door opener without an issue. I am trying to follow above procedure to erase the wifi setting and follow the instruction on the app. Garage door opener that is installed doesn't have up & down arrows keys as well as black button. How do I erase wi fi settings in such a case? - Thanks.
Photo of MyQ Community Manager

MyQ Community Manager

  • 2294 Posts
  • 143 Reply Likes
sandeep, I've requested a customer support agent contact you in order to sort this out. Thank you for sharing the info, someone will be in touch with you soon. Lauren
Photo of bruce

bruce

  • 1 Post
  • 0 Reply Likes
Same issue, truly believe I follow all the above recommendations but still cannot add the second hub
Photo of Joe

Joe

  • 2 Posts
  • 0 Reply Likes
For anyone finding this recently, I was experiencing the same problem. I went into the app, selected the first hub, select add garage door, then next, then would push the learn button on the opener on my wall, and it would just never find the second door. To get it working, I reset the Wifi by pushing the middle button on the back of the motor unit for 6 seconds. Then I followed the same process as above and pushed the round learn button on the back of the motorized unit itself while my phone was really close, then it worked.  ̄\_(ツ)_/ ̄
Photo of Douglas Acheson

Douglas Acheson

  • 2 Posts
  • 0 Reply Likes
I followed the instructions on here as well, as first (4 attempts) the app just timed out.  Finally, it worked.  Then when I tried to open/close the GDO via the app, I was surprised to find that the GDOs started to flash and beep just like when the sensor is blocked.  I continued to press the app close button (sure frustration) then they closed.  I will have to test again to see if it happens - too frustrated to hear the beeping right now ...

dwfa
Photo of Joe

Joe

  • 2 Posts
  • 0 Reply Likes
It beeps to ensure awareness to those around that it's closing...then it closes about 10 seconds later
Photo of Douglas Acheson

Douglas Acheson

  • 2 Posts
  • 0 Reply Likes
Thanks for the quick response.  I sorta understand; however, I do not recall the "warning" happening when I only had one GDO registered via myQ.  In any case, can I turn off this warning?
Photo of Travis Renfroe

Travis Renfroe

  • 1 Post
  • 0 Reply Likes
I have tried following the instructions for adding the second gdo and the app never finds it. I am trying to add it to a new myq home bridge.