Suddenly stopped connecting to Wi-Fi - SOLVED

  • 1
  • Question
  • Updated 2 weeks ago
  • (Edited)
I got the MyQ Hub (G0301-D) in June of this year and set it up with two garage doors with no problem. I assigned an IP Address and while it didn't have the best connected reliability it worked ~70% of the time when I needed it (I used a backup the 30% of the time). I upgraded my router (From Archer C7 to Archer C2300) but maintained the same settings and suddenly not connecting to Wi-Fi. I migrated all my settings over, kept the 2.4GHz channel at the 20MHz width, opened the ports (53 external and 8883 internal), disabled firewall and antivirus... and still nothing. I did a wifi analysis in the garage where it is placed and it receives excellent signal on a 2.4GHz b/g/n wi-fi in channels 1, 6 and 11. I brought it in the house and tried setting it up in front of the router, nothing. I tried installing the old router there again with the previous settings and it works. I literally went tab by tab and making sure everything is the same and it still won't connect. Funny thing is that looking at the log it seems the last time the MyQ was connected was 4 hours prior to me changing routers. I am running out of ideas at this point and looking for a little more guidance. Any help is appreciated.

I am following the recommended router settings (https://support.chamberlaingroup.com/s/article/Recommended-router-settings-for-the-MyQ-Wi-Fi-product...)

My router is compatible (https://support.chamberlaingroup.com/s/article/Which-routers-are-not-compatible-with-the-Wi-Fi-Garag...)


Edit - So I figured it out. Another device had a static IP address that matched that of the MyQ hub, when I released the IP Address it worked like a charm. Not sure why it became an issue when I changed routers since the issues was going on long before that. I did try to widen the Wi-Fi channel (for improved speeds) and sure enough the hub can't connect. Otherwise, it's back to it's working state. Hopefully my mistake helps someone.
Photo of TA DB

TA DB

  • 1 Post
  • 0 Reply Likes
  • relieved

Posted 9 months ago

  • 1
Photo of Gary Hasul

Gary Hasul

  • 2 Posts
  • 0 Reply Likes
I have an Archer A7 router and just installed a Chamberlain MyQ garage door opener.  I can get it to connect to the router, but not the internet.  MyQ support tells be that is because 53 and 8883 are not open.  TP-Link support tells me to add 2 entries to the NAT Forwarding > Virtual Servers page.
I added 53 and 8883, but it still is not connecting.  You say  "opened the ports (53 external and 8883 internal), disabled firewall and antivirus"  Did you do anything different?   Can you tell me what they mean by External and Internal?  Right now I'm stuck and going nowhere.