Replaced battery in sensor - now both doors open at the same time?

  • 1
  • Question
  • Updated 3 months ago
I have a MyQ hub with 2 door sensors.  Garage doors are Chamberlain Whisperdrive WD822KLD/47995D.
I went into the app the other day and it said it couldn't talk to either door.  When I went to try to open the door, the lovely iOS app removed both door sensors (I didn't do anything, they just disappeared). 

So the app then walks me through the add a device, and that's when I discover that the battery had died on the door sensor.  OK, go get new ones.
I add the first door and it opens both garage doors.
WTH?
I know when I set this up the first time I did not have to reprogram the garage door units at all (other then pressing the purple learn button briefly until the light goes on), although it seems only one person got a method to work. 

I see another thread that has you go through a horrible process of totally reprogramming the garage door opener itself, then the remotes, then the vehicles, and everything else you ever used to have hooked up to the opener.
I've tried a factory reset on the hub, as well as deleting the app from the phone to clear everything out.  I even tried GK's post steps (where you basically unplug one door opener while setting it up, then do the same to the other).   No go.
Photo of Kevin Hurni

Kevin Hurni

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 1 year ago

  • 1
Photo of Chamberlain Admin

Chamberlain Admin, Official Rep

  • 343 Posts
  • 14 Reply Likes
Hi Kevin,

Thank you for reaching out to us. We are sorry that your experience with the Smart Garage Hub sensor has not met your expectations. Can you email us at social@chamberlain.com with the subject line "MyQ Community- Kevin Hurni." That way we can receive your email address privately and escalate your issue. 
Photo of Bill Horn

Bill Horn

  • 1 Post
  • 0 Reply Likes
same issue.  What is the resolution?

Photo of Darrin Forbes

Darrin Forbes

  • 1 Post
  • 0 Reply Likes
Same issue here.  Please let us know the resolution
Photo of Kevin Hurni

Kevin Hurni

  • 2 Posts
  • 0 Reply Likes

Unfortunately by the time I saw the reply to email the social@chamberlain.com I had already spent about an hour climbing up and down ladders to reset the openers and then had to re-program all the remotes.  Royal PITA.
Photo of Jim Guillory

Jim Guillory

  • 1 Post
  • 0 Reply Likes
I’m having this same problem and this thread is not offering a solution.

I have have my 2 MyQs for a couple of years now but they haven’t worked for about 1.5 years. I only recently found that the batteries in the door sensors were dead. So I changed them. Apparently I then have to reprogram them with the hub and openers.

So I replaced the batteries, and followed the setup procedure. I can get one door programmed normally but then I have trouble getting the other door to program. It will connect, open and close the door but it then tells me the program didn’t work and I need to try again. Trying again never works. Even though I apparently don't get the one opener to program it will still open the door but it opens both at the same time.

I think I’ve tried every combination of troubleshooting steps possible but nothing is working. Can you please help?!