Problem setting up myQ garage to Liftmaster Professional 1/2HP chaindrive

  • 1
  • Question
  • Updated 12 months ago
Got the MyQ Garage. Have it setup to my wifi network no problem. The garage door sensor is paired no problem but I couldn't get my garage door opener to learn the signal from the MyQ device. My garage opener is the Liftmaster Professional 1/2HP chain drive from 2007. The learn button is purple. Tried setting up via the iOS app. Pushed the learn button when prompted, nothing happened. 30sec was gone and the learn indicator light went out on the opener. Tried setting it up manually by pushing the set up button on the MyQ; two presses on button1 for purple learn button; then setup button again, got the green and yellow light blinking; pushed the purple button on the opener, indicator light went on, nothing happened. Tried setting up my remote again and it was setup instantaneously. Am I missing something here? 
Photo of charles k

charles k

  • 2 Posts
  • 0 Reply Likes

Posted 12 months ago

  • 1
Photo of MyQ Community Manager

MyQ Community Manager, Official Rep

  • 798 Posts
  • 43 Reply Likes
Hi Charles, looking into an answer for you. More soon.  Chuck
Photo of MyQ Community Manager

MyQ Community Manager, Official Rep

  • 798 Posts
  • 43 Reply Likes
Charles, I'm sending troubleshooting tips, below. Let me know if this helps, or if you'd prefer we contact you via email for additional assistance.  Chuck

1.    Log into your MyQ account.

2.    Tap the + sign.

3.    Press Add Device (Android) or Add To: Place (Apple).

4.    Select the type of device you want to add.

·         Garage Door Opener If using a MyQ Garage follow these steps

1.    If you are using a door sensor, tap yes.

2.    Locate the door sensor, press the test button, then tap Next on the app.

3.    Once the MyQ Garage beeps, select the Brand/Model of your garage door opener.

4.    If you are prompted to, select the color or learn button then press "Program Door Control" OR

5.    Proceed by pressing Program Door Control to continue.

6.    Follow the on-screen prompts.

7.    When the device was added, name your device and click save.

Photo of charles k

charles k

  • 2 Posts
  • 0 Reply Likes
Found out what the problem is. Moved the device another foot away from the garage opener, setup went flawless. Everything works now. Thanks for the help.
Photo of MyQ Community Manager

MyQ Community Manager, Employee

  • 2294 Posts
  • 139 Reply Likes
Great to hear. Thanks for letting us know. Chuck