Pairing opener switch to hub causes opener light to come on randomly

  • 1
  • Problem
  • Updated 3 years ago
I installed the MyQ retrofit kit to my 10-year old garage door.   It included the motion-sensing switch and the hub.  I hooked up the switch first and enabled motion sensing to turn the opener light on when motion is detected.  It was working perfectly for over a week.  Once I paired the switch to the hub, the opener light now comes on randomly.  I ended up disabling motion sensing on the switch because the opener light would stay on almost constantly.  Any idea what could be wrong?
Photo of David Moore

David Moore

  • 6 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Dawn

Dawn, Official Rep

  • 274 Posts
  • 63 Reply Likes
David - Is it turning on when someone crosses the safety sensor beam at the bottom of the garage? Or just random times? 
Photo of David Moore

David Moore

  • 6 Posts
  • 0 Reply Likes
Totally random.  The door is down and the light comes on.  I can push the button to make the light go off and I'll go out in the garage later and the light is on again.
Photo of Dawn

Dawn, Official Rep

  • 274 Posts
  • 63 Reply Likes
The motion sensor detects heat. Anything warm turning on in the garage?

Sometimes it could be another door control too close. Do you have any other door controls installed near this one? 
Photo of David Moore

David Moore

  • 6 Posts
  • 0 Reply Likes
Yes, there is another door control installed near this one.

The control is installed directly across from the freezer in the garage.  If the door control detects heat and not movement, then I bet the freezer kicking on and off is causing the door control to sense heat and trigger the light.
Photo of Dawn

Dawn, Official Rep

  • 274 Posts
  • 63 Reply Likes
I apologize for the delay in my response to this. Depending how close the other door control is installed it may also be the culprit. My suggestion would be to turn off the motion detector at this point.