MyQ releasing Wifi Hub so it can be assigned to Alarm.com

  • 1
  • Question
  • Updated 3 weeks ago
  • (Edited)
I just replaced my older Liftmaster opener with a new Chamberlain opener.  The original Liftmaster opener was integrated with my Alarm.com system through a MyQWifi hub.  After I installed the new opener I had to reprogram the hub to work with the new opener. During this process I donwloaded and installed the MyQ app and setup the hub with the app.  I completed setup and everything worked fine.  I assumed there wouldn't be a conflict if the hub was setup in MyQ as well as Alram.com.  I was wrong.  The problem is the hub/opener is no longer visible in my Alarm.com app.  I went into my Alarm.com account and attempted to add the hub back in but it stated that it was already assigned to a Liftmaster MyQ account.  I took this to mean I had to choose either to control the door through the Alarm.com app or the MyQ app.  I chose the Alarm.com app because that's how I control all my other home automation.  I removed the hub from the MyQ account and have attempted to add it to my Alarm.com account.  After over an hour the alarm.com site still says, "This gateway ('0400xxxxxx') is associated with an existing MyQ LiftMaster account. You must use the LiftMaster mobile app or website to remove the gateway or place from your MyQ account. Once the gateway is free, you can try again."   So my question is, how long does it take MyQ to free up the hub?  I had to do a similar thing with my cameras when I switched security companies and those devices got released instantly.
Photo of Donovan Lee

Donovan Lee

  • 2 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of MyQ Community Manager

MyQ Community Manager

  • 161 Posts
  • 95 Reply Likes
Hi Donovan, 

I believe this can be done rather quickly over the phone through the customer service center. One the reps will need to disassociate your gateway hub with your MyQ account. Make sure you have your hub's serial number on hand. From there, you'll have to reconnect your hub to your new garage door opener. Hope that helps. 
(Edited)
Photo of Donovan Lee

Donovan Lee

  • 2 Posts
  • 0 Reply Likes
Thanks.  Customer Support was very helpful and got the issue fixed in just a few minutes.  Real helpful and didn't ask me a lot of lame questions before we could even start like a lot of customer service lines do.  Also, thanks for keeping your call center/help desk in the U.S and not outsourcing it to India.

If anyone else has a similar issue, you need to do a hard reset on the hub.  Hold the gear button three times for 30 seconds each.  You'll here some beeps and the light will flash.  You need to time it because there is no indication when the 30 second intervals are up.  Once this is done you need to reconnect the hub to your wireless network and pair it with your garage door opener.  Then you can go into the alarm.com app and add the hub.
(Edited)
Photo of Hassan Gawad

Hassan Gawad

  • 2 Posts
  • 0 Reply Likes
Donovan
I had the exact problem. I removed the hub from MyQ cloud, I did the hard reset but my alarm.com still cannot see the MyQ hub. Although it is in Access Point mode and I can see that that my laptop wifi can see it! any tips?
Photo of James Laurie

James Laurie

  • 4 Posts
  • 0 Reply Likes
Can you use both the MyQ and Alarm.com apps at the same time?
Photo of Scott Hibbs

Scott Hibbs

  • 1 Post
  • 0 Reply Likes
I WISH!!! I had to pick one or the other. I picked Alarm.com..

Alexa (Amazon Echo) can control the opener with my home automation (home assistant) and MyQ. However, I don't allow control of my home from the internet. 

But, Alarm.com has the nice android app that alerts me when the door is open and the ability to open/close anywhere in the world. However, I can't say "Alexa, tell Alarm.com to open the garage door" .... She coldly states, "Opening Garage doors is currently not supported."   :(   

So now I'm building my own Arduino device and learning to "hack" my garage door (why I'm here). Just so I can tell Alexa to do it and instead of finding my phone, logging in....