MyQ App does not work when I'm not home

  • 1
  • Question
  • Updated 3 months ago
I have a LiftMater Security+ 2.0 garage door opener and although the MyQ app works fine from my iPhone when I am connected to the network WiFi at home, it does not work at all when the phone is not on the network. Is there a solution for this? 
Photo of David Suarez

David Suarez

  • 3 Posts
  • 1 Reply Like

Posted 3 months ago

  • 1
Photo of Michael Parker

Michael Parker

  • 322 Posts
  • 33 Reply Likes
You may need to setup port forwarding on your router. It sounds like it is blocking the port myQ uses when you are outside your local network
Photo of David Suarez

David Suarez

  • 3 Posts
  • 1 Reply Like
That's possible.  Although I wouldn't know how to fix that.  What is actually happening is that the myQ app on my phone errors out with the message "ERROR There was an error connecting to the server. Please check your connection and try again" when the phone is not connected to the WiFi network at home. 
Photo of Michael Parker

Michael Parker

  • 322 Posts
  • 33 Reply Likes
You’d have to find out what port myQ communicates out on then login to router and forward the port from the ip that the myQ uses. I can’t really assist but your router manufacturer/isp could help if you know the port from chamberlain
Photo of Sir MAK

Sir MAK

  • 32 Posts
  • 3 Reply Likes

Check your phone settings.  Make sure the MyQ app is enabled for Cellular Data.
 Setting>Cellular -  then look in the list for either the LiftMaster or Chanberlain app and make sure it's enabled.
(Edited)
Photo of David Suarez

David Suarez

  • 3 Posts
  • 1 Reply Like
That worked! Simple solution! Thank you for sharing your problem solving skills!
Photo of Michael Parker

Michael Parker

  • 322 Posts
  • 33 Reply Likes
I feel stupid for not thinking of that lol