HomeKit: No Response for Garage Door

  • 3
  • Question
  • Updated 7 months ago
I was successfully able to set up the myQ HomeKit Bridge with my garage opener (with myQ built-in).  I then used a myQ Hub to add an older garage opener and subsequently transfer it to the HomeKit Bridge.

With my account, I was able to open/close with the Home app as well as with Siri.

I then invited my wife to share everything.  Her status reported "no response" and the HomeKit Hub (our master bedroom AppleTV) was listed as not connected.  I had tried to get the living room AppleTV set up earlier.  I was unable to do so.

Now my phone is showing both devices as no response.  I rebooted my phone several times, rebooted both AppleTV's, etc.  No luck.  I even tried disconnecting the living room AppleTV as a hub. No luck.

Any thoughts?  I have a feeling I'm going to need to reboot the bridge, which I'm not looking forward to toting the ladder from the basement just to reboot it.

Thanks!
Photo of Eric

Eric

  • 6 Posts
  • 6 Reply Likes

Posted 11 months ago

  • 3
Photo of MyQ Community Manager

MyQ Community Manager, Employee

  • 2294 Posts
  • 139 Reply Likes
Eric, looking into this for you. Will let you know what I find out. Lauren 
Photo of Eric

Eric

  • 6 Posts
  • 6 Reply Likes
Rebooted the bridge and still no response listed in HomeKit for the bridge and my two openers.

I've spent over 6 hours on this tonight.  :(
Photo of chris

chris

  • 48 Posts
  • 1 Reply Like
I’ve had success with other devices by signing out of iCloud and signing back in (I use IPad as hub so for you Apple TV)
Photo of Eric

Eric

  • 6 Posts
  • 6 Reply Likes
I think I figured out the problem.  I have the MyQ set up in a separate VLAN for IoT devices.  If I switch my iPhone to that SSID, everything works.  I think my AppleTV cannot see across the VLAN (even though I enabled interVLAN traffic temporarily to test it).  Will reprogram it to my main VLAN to see if that resolves the issue.  
Photo of MyQ Community Manager

MyQ Community Manager, Employee

  • 2294 Posts
  • 139 Reply Likes
Eric, that's great to hear. Let us know if anything changes. Lauren
Photo of Eric

Eric

  • 6 Posts
  • 6 Reply Likes
It's working now.  I think there is some broadcast traffic between AppleTV's and the MyQ that doesn't occur across VLAN's (even if a firewall allows inter-VLAN traffic).

Will see if it's working on my wife's iPhone when she gets home tonight, but I was able to open the garage door from the entrance to our neighborhood using Siri.

Her garage opener is an older opener that I had to use a MyQ Hub.  When I set it up the first time, I had to set it up and then later transfer it to my bridge.  It's still set up with the old bridge settings.  Is there a way to transfer things without needing to set it up for WiFi and then transfer?  The reason I ask is because I've already mounted it on the ceiling.
Photo of JDMAN

JDMAN

  • 26 Posts
  • 2 Reply Likes
Eric, I have the same setup. MyHub+ MyQ-303 for HomeKit. Under the iOS Home app it show up as a "Gateway" (reverse looking triangle). Very odd. Obviously not able to open or close... I can open from within the Chamberlain app. But that defeats the purpose.
Photo of Dave Stewart

Dave Stewart

  • 3 Posts
  • 0 Reply Likes
Having the same problem. Works in app but not HomeKit
Photo of MyQ Community Manager

MyQ Community Manager, Employee

  • 2294 Posts
  • 134 Reply Likes
Dave, what devices are you using and could you please share other relevant details, so we can help you find a resolution? Thanks, Lauren
Photo of Dave Stewart

Dave Stewart

  • 3 Posts
  • 0 Reply Likes
I have 2 my garage door openers and a myq bridge.
Photo of MyQ Community Manager

MyQ Community Manager, Employee

  • 2294 Posts
  • 134 Reply Likes

Dave, we recommend that you delete the garage door openers from the HomeKit app and then set up the accessories in HomeKit. Here's the guide for that set up: https://support.apple.com/en-us/HT204893#add. Let us know how that goes and if you need additional support. Thanks, Chuck

Photo of Dave Stewart

Dave Stewart

  • 3 Posts
  • 0 Reply Likes
The door openers don't appear in homekit, only the bridge and it says "not responding". I have tried reseting router, and devices but nothing changes.
Photo of MyQ Community Manager

MyQ Community Manager, Employee

  • 2294 Posts
  • 134 Reply Likes
Dave, have you contacted Apple about this issue? If the MyQ app is working and the garage door openers are not showing up in HomeKit, it might be helpful to get in touch with Apple to see why the MyQ devices aren't showing up on HomeKit. -Chuck