Green light flashes, can't connect to MyQ Server

  • 2
  • Question
  • Updated 2 months ago
My MyQ account has been working great since I installed my units a few months ago.  However, yesterday, I noticed my garage doors were offline and I was getting the error #309.  I noticed the green LED was flashing, meaning that I was not getting connection to the servers.  I tried rebooting the hub, my router, trying different ports on the router, and soft reset.  Nothing has worked.  

Any thoughts?
Photo of Clay Whitenack

Clay Whitenack

  • 6 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 2
Photo of MyQ Community Manager

MyQ Community Manager

  • 2294 Posts
  • 145 Reply Likes
Clay, please start by checking the power and network connections. If everything is in order, let me know and we'll figure out next steps. Lauren
Photo of Clay Whitenack

Clay Whitenack

  • 6 Posts
  • 0 Reply Likes
Thanks for the reply.  Yes, everything is plugged in and working.  I have a blue led and a blinking green led.  The router is on and connected to the internet.  My other devices have access to the internet.  On my router's admin page, I see the Hub connected to the router.
Photo of MyQ Community Manager

MyQ Community Manager

  • 798 Posts
  • 43 Reply Likes
Clay, I'm looking into more info for you.  More soon.  Lauren
Photo of Clay Whitenack

Clay Whitenack

  • 6 Posts
  • 0 Reply Likes
Hey Lauren.  Any thoughts on this?
Photo of MyQ Community Manager

MyQ Community Manager

  • 2294 Posts
  • 145 Reply Likes
Clay, please make sure the following ports are open: 1) TCP/UDP port 53 open (DNS), 2) Inbound and outbound UDP port 80 open, 3) Inbound and outbound TCP port 2165 open, 4) Inbound and outbound UDP/TCP port 8883 open. Let me know the status and we'll figure out next steps. Lauren
Photo of Clay Whitenack

Clay Whitenack

  • 6 Posts
  • 0 Reply Likes
Thanks for the reply.  After reading your suggestions, I looked into my router settings.  I didn't have any ports blocked, but started tinkering with my firewall settings.  Turning off the router firewall completely allowed the hub to connect.  I turned the firewall back on and it continued to work.  So, it seems to be fixed for now.  If it causes trouble again, I will look into seeing how to allow the hub to get through the firewall.
Photo of MyQ Community Manager

MyQ Community Manager

  • 2294 Posts
  • 145 Reply Likes
Clay, good to hear it is up and running! Lauren
Photo of Clay Whitenack

Clay Whitenack

  • 6 Posts
  • 0 Reply Likes
Ok, an update since last week.  After working for a day or two, it stopped working again.  I went back into my router settings and tried to play around with the port forwarding settings.  I set the Hub up on a static IP and then forwarded the ports to that IP address (I think...I'm not exactly sure what I'm doing).  That worked for a day or two, then quit working again.  I went back into the router settings, checked to make sure the port forwarding rules were still active.  They were.  So I just rebooted the router, and that got it working again.  A day later, it stopped.  I have rebooted the router again but that hasn't helped.  I turned off the router firewall and that hasn't helped either.  So, I'm stuck again and out of ideas.  
Photo of MyQ Community Manager

MyQ Community Manager

  • 2294 Posts
  • 145 Reply Likes
Clay, I would like to connect you with our support team. Is the email associated with your MyQ account a good one for us to reach you at? Lauren
Photo of Clay Whitenack

Clay Whitenack

  • 6 Posts
  • 0 Reply Likes
Yes.  That would be great.  Thanks.
Photo of bryan

bryan

  • 3 Posts
  • 0 Reply Likes
Clay, did you get any resolution for this? I’m having the same problem and have no idea what router settings I need an order for this to work. Thanks
Photo of BAHusky

BAHusky

  • 1 Post
  • 0 Reply Likes
I got the same issue.  My MyQ just stopped working 10 days ago and the green light is just flashing.  What port needs to be open on the router to make this work?  Is there any port that needs to be opened on the router to make this work?

Rob
Photo of Will

Will

  • 5 Posts
  • 0 Reply Likes
53 and 8883 are in a troubleshooting guide from the manufacturer site.
Photo of Will

Will

  • 5 Posts
  • 0 Reply Likes
Similar issue for me. I have two units, and after reviewing some troubleshooting info here, I could only port forward to one of them (ports 53 and 8883). Now that one seems to work, but the other goes offline intermittently. How can I open the ports to accommodate both of my devices? I have a MyQ872 and 70c, and this didn't happen until I got a new router. I don't have connectivity issues with anything else. The wifi stays connected, but I lose the internet connection to the server. I found this information by going to the IP address of my device: 
Powered Time2 hours, 48 minutes, 54 seconds; Internet ConnectedYes; Connected Time31 minutes, 34 seconds; Router Connections Since Powerup 1; Internet Connections Since Powerup 4
Photo of Will

Will

  • 5 Posts
  • 0 Reply Likes
I may have my answer from:Two MyQ-integrated openers in one 'Location'? 

Photo of Will

Will

  • 5 Posts
  • 0 Reply Likes
Now both openers are on one hub, and I thought I solved the problem. But they still go offline, just together now.