Garage Door says "No Response" in Home app, but works in MyQ app

  • 1
  • Question
  • Updated 6 months ago
  • (Edited)
In the Home app on my iphone 7 the Garage Door says No Response when I try and control thru the Home app.  I get status updates thru home just fine and I can open/close via the MyQ app just fine.  I am using an Ipad Air as my hub and all my other homekit devices work as they are supposed to.  I have tried to delete everything and start from scratch and that worked a total of one time before I started getting the No Response error again.  Please advise.  TIA for your help!
Photo of Bob

Bob

  • 11 Posts
  • 0 Reply Likes

Posted 7 months ago

  • 1
Photo of Michael Parker

Michael Parker

  • 274 Posts
  • 28 Reply Likes
I had had that happen a couple of times as well there are a few possible causes

The MyQ opener may have a fluctuatingly weak wifi signal to your wifi. Try moving it or your wifi source closer together.

I added a wifi access point to my garage to make sure my signal is 100% in my detached garage

The disconnect still happens from time to time and a power cycle of the MyQ bridge and MyQ opener are required so to resolve that without putting on boots and jacket to go power cycle I added an iHome outdoor smart plug that is HomeKit compatible and can use it to power cycle the chamberlain gear when needed.

I would say since adding the wifi access point which acts as a booster it happens far less than it did before so try moving the chamberlain devices and router or wifi source a little closer together.
Photo of Jim

Jim

  • 70 Posts
  • 9 Reply Likes
Check that the iPhone is on the latest iOS version.  If not, update to latest version.
Photo of Bob

Bob

  • 11 Posts
  • 0 Reply Likes
Yes the iphone is on 11.3.1 which is the latest
Photo of Michael Parker

Michael Parker

  • 274 Posts
  • 28 Reply Likes
Is the iPad as well?
Photo of Bob

Bob

  • 11 Posts
  • 0 Reply Likes

Yes it is.


I believe I have had this problem since I originally installed the home bridge when I received a free one, but this is the first time I have gotten around to trying to figure out what is wrong...

Photo of Michael Parker

Michael Parker

  • 274 Posts
  • 28 Reply Likes
Wish the chamberlain app had a diagnostics mode on it to check signal strength and other options

My last suggestion is to call in with tech support. Have it removed from the apps, wiped back to factory, and reset up as a new product it might be some bug in the initial wifi settings, HomeKit can always be looking for it and if it drops even once HomeKit may be ignoring it until it calls home again.

Next step if that fails is maybe having a chat with Apple about it

Explain it’s only HomeKit habit the issue and not the chamberlain app. Maybe they can see an issues between their HomeKit servers and chamberlains link to them

I know when this add on bridge first came out a lot of reports of HomeKit specific issues but seemed to resolve over time