Does MyQ Home Bridge not work when off wifi network?

  • 2
  • Question
  • Updated 10 months ago
  • (Edited)
I have Home Kit set up with an Apple TV4 as a hub and everything in Home Kit works off my home network except my garage door.  It's greyed out (and says "No response").  It works fine if I'm home.  But as soon as I leave the house it greys out / disconnects.  Sort of ruins half the reason I wanted MyQ Home Bridge - to be able to open my garage door by voice as I am entering my neighborhood.  Am I doing something wrong?
Photo of Jack

Jack

  • 3 Posts
  • 0 Reply Likes

Posted 10 months ago

  • 2
Photo of michael.lebiedzi

michael.lebiedzi

  • 16 Posts
  • 1 Reply Like
Is the device you are carrying outside the house signed into the same iCloud account as the Apply TV v4, or an account in the same Family Sharing setup? I had a similar problem when I installed my system, and found this to be the problem. There is a status screen on the Apple TV 4 that shows the HomeKit connection status. Good Luck. hope this helps
Photo of Jack

Jack

  • 3 Posts
  • 0 Reply Likes
Thanks.  Yes both the device and the Apple TV are logged into the same iCloud account.

The AppleTV is configured to run as a hub as everything else in the Home app works off my wifi network. Only the Chamberlain garage door stops working when I drive away from home.
Photo of michael.lebiedzi

michael.lebiedzi

  • 16 Posts
  • 1 Reply Like
This happens to me sometimes, and seems to be related to the strength of the wifi signal in the driveway and switching from wifi to cellular. does the status update and can you control the GDO after driving a bit away from your house, or does remote access when outside you house ALWAYS never work?
Photo of Jack

Jack

  • 3 Posts
  • 0 Reply Likes
I made it work finally.  It took more than 35 resets of the Home Bridge (yep for real).  I can't say for sure everything that I did that made it work (because there were 35+ iterations), but one thing is for sure - I had to reset Apple HomeKit to new (yes and set up all my Home devices again after Chamberlain was working), and erase everything in the Chamberlain MyQ app and delete and reinstall it.  If I didn't do these two steps, it definitely wasn't working (and wasn't working some times when I did do this step).  But leaving all your old data and setup in the MyQ app (as Chamberlain says to do) did NOT work for me at all. YMMV but that is what worked for me. This was a colossal pain in the butt and way more work that it should have been.